フォロー

【for 鯖缶】
次のMastodon 2.7が安定している保証はない(また色々変わる)んだけど、古いバージョンを維持するのも決して簡単ではないので、続けていくなら最新版にいつでも切り替えられるように準備しておいて、適用タイミングを調整するだけにしておいた方がいいよ。

なぜ古いバージョンの維持が難しいかというと、rubyであったり、gemであったり、yarn、yumやaptなどで入れている様々なパッケージ(周辺ソフトウェア・ライブラリ)も常に変化していて、再インストールにあっさり失敗しちゃったりするからです。

現状、Dockerはビルドに失敗するようだし、さくらのVPSのスタートアップスクリプトもダメっぽい。

こういうの、結局、古いのを放棄して、最新版で修正をかけていくので、自力でなおせないと解決できないのです。

ログインして会話に参加
DTP-Mstdn.jp

DTP-Mstdn.jpは、DTP・デザイン・印刷に関わる人々のためのMastodonインスタンスです。

特定分野の専門インスタンスですので、日々のつぶやき、耳寄りな情報の共有、ディスカッション、質問とその回答、役立つスクリプトなど、他では投稿しづらい内容も、思う存分トゥートしましょう!

また、普段使いのインスタンスとしてもご活用ください!
Mastodonは相互に繋がっており、DTP-Mstdn.jpを通じて世界中のインスタンスにアクセスできます。